Installation

Hist is available on PyPI. You can install this library from PyPI with pip:

python3 -m pip install "hist[plot]"

If you do not need the plotting features, you can skip the [plot] extra.

You can also install it with Conda from conda-forge.

conda install -c conda-forge hist

Supported platforms are identical to boost-histogram, though for the latest version of Hist you need Python 3.7+.